CCNPv7.1_SWITCH_Lab6-3_GLBP_INSTRUCTOR

, Configure GLBP

SWITCH

 

INSTRUCTOR VERSION

Topology

 

Objectives

• Configure trunking, VTP, and using router-on-a stick

Configure GLBP

priorities

object tracking.

Background

 

GLBP) performs a similar function in redundancy, but offers the capability to load balance over multiple gateways.

the load of frames that, from a client perspective, are sent to a single default gateway address.

GLBP allows for simultaneous forwarding from routers participating in a GLBP group. GLBP can support up to 4 routers in a group. GLBP also offers authentication and object tracking.

Once the network is set up, you will configure and verify GLBP.

 

g any release).

(2): The 3 switches in this topology are only being used to support layer-2 functions, so 3 Cisco 2960 switches are acceptable for this lab. All Inter-VLAN routing will be facilitated by implementing a router-on-a-stick on R1 and R3.

This lab’s topology is based on the NETLAB Multi-Purpose Academy Pod (MAP). If your classroom is using the standard Cuatro Switch Pod, the PC names may be different than displayed here. Consult with your instructor.

Required Resources

image or comparable

image or comparable

• Threeor comparable)

and console cables

3 PC’s with Windows OS

 

 

Step 1: Prepare the switches for the lab   

copy flash:BASE.CFG running-config. An example from DLS1:

 

tclsh reset.tcl

Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]

[OK]

Erase of nvram: complete

Reloading the switch in 1 minute, type reload cancel to halt

 

Proceed with reload? [confirm]

 

*Mar 7 18:41:40.403: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram

*Mar 7 18:41:41.141: %SYS-5-RELOAD: Reload requested by console. Reload Reason: Reload command.

<switch reloads — output omitted>

 

n

en

*Mar 1 00:01:30.915: %LINK-5-CHANGED: Interface Vlan1, changed state to administratively down

copy BASE.CFG running-config

Destination filename [running-config]?

184 bytes copied in 0.310 secs (594 bytes/sec)

DLS1#

Step 2: Configure basic switch parameters.

On each switch, c 99 will be used as the management VLAN.

 

DLS1 example:

Enter configuration commands, one per line. End with CNTL/Z.

interface vlan 99

255.255.255.0

no shutdown

 

The interface VLAN 99 will not come up immediately, because the Layer 2 instance of the VLAN does not yet exist. This issue will be remedied in subsequent steps.

remote access from other network devices.

DLS1 example:

enable secret class

line vty 0 15

password cisco

login

Note: The passwords configured here are required for NETLAB compatibility only and are NOT recommended for use in a live environment.

For purely lab environment purposes, it is possible to configure the VTY lines so that they accept any Telnet connection immediately, without asking for a password, and place the user into the privileged EXEC mode directly. The configuration would be similar to the following example for DLS1:

enable secret class

line vty 0 15

no login

privilege level 15

 

 

Step 3: Configure trunks and EtherChannels between switches.

EtherChannel

command.

Refer to diagram for port channel numbers.

command is required on Cisco 3560 switches. It is not required on Cisco 2960 switches.

fastEthernet 0/1-2

switchport trunk encapsulation dot1q

switchport mode trunk

DLS1(config-if-range)# no shut

Creating a port-channel interface Port-channel 1

 

Refer back to Chapter 3 labs as necessary.

Step 4: .

A sample configuration is provided for you.

DLS2(config)#client

mode for VLANS

Note: Switches default to vtp mode server. However, remember the base configuration modifies this setting to vtp mode transparent.

Step 5: Configure VTP and VLANs on DLS1.

.

.

DLS1(config)#GLBP

DLS1(config)# vtp version 2

DLS1(config)#vtp mode server

Setting device to VTP Server mode for VLANS

 

99

   

Office

20

Server

exit

 

Verify that VLANs propagated to the other switches in the network.

Step 6: switch access ports.

command.

 

interface FastEthernet 0/6

access vlan 10

switchport host

switchport mode will be set to access

spanning-tree portfast will be enabled

channel group will be disabled

 

no shutdown

 

the switchports on DLS1, DLS2 and ALS1 are members of VLAN 10.

Step 7: Configure DLS1 and DLS2 trunking to the R1 and R3 router.

router Gigabit Ethernet interface, according to the topology diagram. An example from DLS1:   

 

interface FastEthernet 0/5

switchport trunk encap dot1q

DLS1(config)#switchport mode trunk

DLS1(config)#no shutdown

 

command is required on Cisco 3560 switches. It is not required on Cisco 2960 switches.

Step 8: Configure basic settings on R1, R2, and R3.

Configure basic settings on all three routers. An example for R1 follows:

enable

conf t

Enter configuration commands, one per line. End with CNTL/Z.

hostname R1

enable secret class

line con 0

logging synchronous

line vty 0 4

password cisco

login

exit

R1(config)#

Note: The passwords configured here are required for NETLAB compatibility only and are NOT recommended for use in a live environment.

In addition to the basic settings on R2, configure interface Loopback 0 with the IP address 10.1.202.1/32

interface loopback 0

ip address 10.1.202.1 255.255.255.255

no shut

exit

Step 9: Configure the R1 and R3 Gigabit Ethernet interfaces for VLAN trunking.

as their default gateway.

VLAN

R1

R3

99

10.1.99.1/24

10.1.99.2/24

10

10.1.10.1/24

10.1.10.2/24

20

10.1.20.1/24

10.1.20.2/24

 

The following is a sample configuration for the Gigabit Ethernet 0/1 interface:

interface GigabitEthernet0/1

no shut

GigabitEthernet0/1.10

0

.1 255.255.255.0

GigabitEthernet0/1.20

VLAN 20

encapsulation dot1q 20

.1 255.255.255.0

GigabitEthernet0/1.99

description Management VLAN 99

encapsulation dot1q 99

.1 255.255.255.0

 

from the table above. Hosts on the VLAN can use this address as their default gateway.

command to verify the interface configuration and status.

R1#show ip interface brief

 

Interface IP-Address OK? Method Status Protocol

Embedded-Service-Engine0/0 unassigned YES unset administratively down down

GigabitEthernet0/0 unassigned YES unset administratively down down

GigabitEthernet0/1 unassigned YES unset up up

GigabitEthernet0/1.10 10.1.10.1 YES manual up up

GigabitEthernet0/1.20 10.1.20.1 YES manual up up

GigabitEthernet0/1.99 10.1.99.1 YES manual up up

Serial0/0/0 unassigned YES unset administratively down down

Serial0/0/1 unassigned YES unset administratively down down

Serial0/1/0 unassigned YES unset administratively down down

Serial0/1/1 unassigned YES unset administratively down down

 

to verify inter-vlan routing configurations. The following is a sample output from router R1. Verify configurations on router R3.

 

show vlans

 

Virtual LAN ID: 1 (IEEE 802.1Q Encapsulation)

 

vLAN Trunk Interface: GigabitEthernet0/1

 

This is configured as native Vlan for the following interface(s) :

GigabitEthernet0/1 Native-vlan Tx-type: Untagged

 

Protocols Configured: Address: Received: Transmitted:

 

GigabitEthernet0/1 (1)

Other 0 19

 

17 packets, 5572 bytes input

19 packets, 1856 bytes output

 

Virtual LAN ID: 10 (IEEE 802.1Q Encapsulation)

 

vLAN Trunk Interface: GigabitEthernet0/1.10

 

Protocols Configured: Address: Received: Transmitted:

 

GigabitEthernet0/1.10 (10)

IP 10.1.10.1 0 0

Other 0 2

 

0 packets, 0 bytes input

2 packets, 92 bytes output

 

Virtual LAN ID: 20 (IEEE 802.1Q Encapsulation)

 

vLAN Trunk Interface: GigabitEthernet0/1.20

 

Protocols Configured: Address: Received: Transmitted:

 

GigabitEthernet0/1.20 (20)

IP 10.1.20.1 0 0

Other 0 1

 

0 packets, 0 bytes input

1 packets, 46 bytes output

 

Virtual LAN ID: 99 (IEEE 802.1Q Encapsulation)

 

vLAN Trunk Interface: GigabitEthernet0/1.99

 

Protocols Configured: Address: Received: Transmitted:

 

GigabitEthernet0/1.99 (99)

IP 10.1.99.1 0 0

Other 0 1

 

0 packets, 0 bytes input

1 packets, 46 bytes output

 

Step 10: Configure EIGRP routing in AS 1 for use with GLBP interface tracking.

s shown in the topology diagram. Also configure EIGRP AS 1 for the 10.0.0.0 network. Below is an example of the configuration:

 

int s0/0/0

ip add 10.1.1.1 255.255.255.252

no shut

 

router eigrp 1

network 10.0.0.0

 

and R3 serial interface s0/0/1 using the addresses shown in the topology diagram, and configure EIGRP AS 1 for the 10.0.0.0 network.

 

 

sh ip eigrp neighbors

EIGRP-IPv4 Neighbors for AS(1)

H Address Interface Hold Uptime SRTT RTO Q Seq

Cnt Num

3 10.1.99.2 Gi0/1.99 14 00:00:21 2 100 0 10

2 10.1.20.2 Gi0/1.20 10 00:00:21 1 100 0 11

1 10.1.10.2 Gi0/1.10 14 00:00:21 1 100 0 12

0 10.1.1.2 Se0/0/0 14 00:00:27 1 100 0 7

 

sh ip eigrp neighbor

EIGRP-IPv4 Neighbors for AS(1)

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

11 00:01:59 4 100 0 9

10 00:02:10 1 100 0 14

 

sh ip eigrp neighbor

EIGRP-IPv4 Neighbors for AS(1)

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

13 00:02:26 2 100 0 8

11 00:02:29 1596 5000 0 17

12 00:02:29 1596 5000 0 16

13 00:02:29 1596 5000 0 15

 

 

 

Verify the routing table and ensure that R1 and R3 can ping the loopbackThis network will be used to test the application of HSRP tracked interfaces.

 

| begin Gateway

 

Gateway of last resort is not set

 

10.0.0.0/8 is variably subnetted, 10 subnets, 3 masks

C 10.1.1.0/30 is directly connected, Serial0/0/0

L 10.1.1.1/32 is directly connected, Serial0/0/0

D 10.1.1.4/30

[90/2172416] via 10.1.99.2, 00:04:15, GigabitEthernet0/1.99

[90/2172416] via 10.1.20.2, 00:04:15, GigabitEthernet0/1.20

[90/2172416] via 10.1.10.2, 00:04:15, GigabitEthernet0/1.10

C 10.1.10.0/24 is directly connected, GigabitEthernet0/1.10

L 10.1.10.1/32 is directly connected, GigabitEthernet0/1.10

C 10.1.20.0/24 is directly connected, GigabitEthernet0/1.20

L 10.1.20.1/32 is directly connected, GigabitEthernet0/1.20

C 10.1.99.0/24 is directly connected, GigabitEthernet0/1.99

L 10.1.99.1/32 is directly connected, GigabitEthernet0/1.99

D 10.1.202.1/32 [90/2297856] via 10.1.1.2, 00:04:15, Serial0/0/0

 

 

| begin Gateway

 

Gateway of last resort is not set

 

10.0.0.0/8 is variably subnetted, 10 subnets, 3 masks

D 10.1.1.0/30

[90/2172416] via 10.1.99.1, 00:05:09, GigabitEthernet0/1.99

[90/2172416] via 10.1.20.1, 00:05:09, GigabitEthernet0/1.20

[90/2172416] via 10.1.10.1, 00:05:09, GigabitEthernet0/1.10

C 10.1.1.4/30 is directly connected, Serial0/0/1

L 10.1.1.6/32 is directly connected, Serial0/0/1

C 10.1.10.0/24 is directly connected, GigabitEthernet0/1.10

L 10.1.10.2/32 is directly connected, GigabitEthernet0/1.10

C 10.1.20.0/24 is directly connected, GigabitEthernet0/1.20

L 10.1.20.2/32 is directly connected, GigabitEthernet0/1.20

C 10.1.99.0/24 is directly connected, GigabitEthernet0/1.99

L 10.1.99.2/32 is directly connected, GigabitEthernet0/1.99

D 10.1.202.1/32 [90/2297856] via 10.1.1.5, 00:05:09, Serial0/0/1

 

From R1, ensure that you can ping the 10.1.202.1 destination address.

 

ping 10.1.202.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.202.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

 

ping 10.1.202.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.202.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

 

 

Step 11: for GLBP operation.

 

you will configure a single GLBP group consisting of two members (R1 and R3). A GLBP group can have as many as four members. A single member will be elected as the AVG, and then routers will be designated as AVFs and their virtual MAC address will be distributed to hosts by the AVG in response to ARP requests.

 

command must be configured.

 

by default.

 

Weighting thresholds are defined in conjunction with interface tracking. This functionality will be demonstrated later in the lab.

 

AVG.

 

The standby address for each VLAN will be the host address 254; VLAN 10 will use 10.1.10.254, VLAN 20 will use 10.1.20.254.

 

on R1.

 

interface GigabitEthernet0/1.10

R1(config-subif)#

R1(config-subif)#glbp 10 priority 150

R1(config-subif)#glbp 10 preempt

R1(config-subif)#exit

R1(config)# interface GigabitEthernet0/1.20

R1(config-subif)#glbp 20 ip 10.1.20.254

R1(config-subif)#lbp 20 priority 150

R1(config-subif)# preempt

R1(config-subif)#exit

R1(config)# interface GigabitEthernet0/1.99

R1(config-subif)#glbp 99 ip 10.1.99.254

R1(config-subif)#glbp 99 priority 150

R1(config-subif)# preempt

Except for the priority command, the same commands are used on the sub-interfaces on R3.

 

Before examining the output, it might be useful to take note of the MAC address of R1 and R3’s G0/1 interfaces.

sho int g0/1 | i bia

(bia acf2.c523.7a09)

R1#

 

show int g0/1 | i bia

(bia acf2.c518.0651)

R3#

 

glbp

 

GigabitEthernet0/1.10 — Group 10

State is Active

1 state change, last state change 00:01:28

Virtual IP address is 10.1.10.254

Hello time 3 sec, hold time 10 sec

Next hello sent in 2.272 secs

Redirect time 600 sec, forwarder timeout 14400 sec

, min delay 0 sec

Active is local

Standby is 10.1.10.2, priority 100 (expires in 7.840 sec)

Priority 150 (configured)

Weighting 100 (default 100), thresholds: lower 1, upper 100

Load balancing: round-robin

Group members:

acf2.c518.0651 (10.1.10.2)

acf2.c523.7a09 (10.1.10.1) local

There are 2 forwarders (1 active)

Forwarder 1

State is Active

1 state change, last state change 00:00:46

MAC address is 0007.b400.0a01 (default)

Owner ID is acf2.c523.7a09

Redirection enabled

Preemption enabled, min delay 30 sec

Active is local, weighting 100

Forwarder 2

State is Listen

MAC address is 0007.b400.0a02 (learnt)

Owner ID is acf2.c518.0651

Redirection enabled, 597.856 sec remaining (maximum 600 sec)

Time to live: 14397.856 sec (maximum 14400 sec)

Preemption enabled, min delay 30 sec

, weighting 100 (expires in 8.384 sec)

<output omitted>

   

 

 

 

 

 

 

operation.

 

glbp brief

Interface Grp Fwd Pri State Address Active router Standby router

Gi0/1.10 10 — 150 Active 10.1.10.254 local 10.1.10.2

Gi0/1.10 10 1 — Active 0007.b400.0a01 local —

Gi0/1.10 10 2 — Listen 0007.b400.0a02 10.1.10.2 —

Gi0/1.20 20 — 150 Active 10.1.20.254 local 10.1.20.2

Gi0/1.20 20 1 — Active 0007.b400.1401 local —

Gi0/1.20 20 2 — Listen 0007.b400.1402 10.1.20.2 —

Gi0/1.99 99 — 150 Active 10.1.99.254 local 10.1.99.2

Gi0/1.99 99 1 — Active 0007.b400.6301 local —

Gi0/1.99 99 2 — Listen 0007.b400.6302 10.1.99.2 —

 

in the GLBP output shows the role of the AVG for group 10. The priority has been set to 150 for this group and the state shows R1 as the active AVG. The virtual IP address is 10.1.10.254. The standby AVG is 10.1.10.2 which is the R3 router.

 

.

 

) correspond to one of the four MAC addresses (01-04) that can be used in GLBP operation.

 

02.

 

Continue the analysis on the remaining lines of output for GLBP.

 

for GLBP group 99?

_______________________________________________________________________________

__________________________________________________________________________________________

 

 

?

__________

 

 

Step 12: Verify PCs can reach R2 L0 using the GLBP gateway

Configure the PCs with the IP Addresses shown in the topology diagram. address 10.1.10.254.

 

DLS1 F0/6.

Connection-specific DNS Suffix . :

Link-local IPv6 Address . . . . . : fe80::a940:91fe:38dd:da0c%10

IPv4 Address. . . . . . . . . . . : 10.1.10.100

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 10.1.10.254

 

18.

 

 

Connection-specific DNS Suffix . :

Link-local IPv6 Address . . . . . : fe80::ee:d834:9d99:45e8%11

IPv4 Address. . . . . . . . . . . : 10.1.10.101

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 10.1.10.254

 

18.

 

Connection-specific DNS Suffix . :

Link-local IPv6 Address . . . . . : fe80::a4d3:c82d:93c4:f2e6%11

IPv4 Address. . . . . . . . . . . : 10.1.10.102

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 10.1.10.254

 

arp –a.

 

Output from SRV1

C:\Users\student>ping -n 3 10.1.10.254

 

Pinging 10.1.10.254 with 32 bytes of data:

Reply from 10.1.10.254: bytes=32 time=1ms TTL=255

Reply from 10.1.10.254: bytes=32 time=1ms TTL=255

Reply from 10.1.10.254: bytes=32 time=1ms TTL=255

 

Ping statistics for 10.1.10.254:

Packets: Sent = 3, Received = 3, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 1ms, Maximum = 1ms, Average = 1ms

 

C:\Users\student>arp -a

 

Interface: 10.1.10.100 — 0xa

Internet Address Physical Address Type

10.1.10.101 00-0c-29-80-cb-b6 dynamic

10.1.10.102 00-0c-29-6a-07-e6 dynamic

10.1.10.254 00-07-b4-00-0a-02 dynamic

10.1.10.255 ff-ff-ff-ff-ff-ff static

169.254.69.232 00-0c-29-80-cb-b6 dynamic

224.0.0.22 01-00-5e-00-00-16 static

224.0.0.252 01-00-5e-00-00-fc static

239.255.255.250 01-00-5e-7f-ff-fa static

 

 

round robin algorithm.

 

 

What MAC Address has been issued to the PC-B client?

 

_____________________________________________________________________

 

OUTPUT from PC-B

 

C:\Users\student>ping -n 3 10.1.10.254

 

Pinging 10.1.10.254 with 32 bytes of data:

Reply from 10.1.10.254: bytes=32 time=2ms TTL=255

Reply from 10.1.10.254: bytes=32 time=1ms TTL=255

Reply from 10.1.10.254: bytes=32 time=1ms TTL=255

 

Ping statistics for 10.1.10.254:

Packets: Sent = 3, Received = 3, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 1ms, Maximum = 2ms, Average = 1ms

 

C:\Users\student>arp -a

 

Interface: 10.1.10.101 — 0xb

Internet Address Physical Address Type

10.1.10.100 00-0c-29-15-ab-9d dynamic

10.1.10.102 00-0c-29-6a-07-e6 dynamic

10.1.10.254 00-07-b4-00-0a-01 dynamic

10.1.10.255 ff-ff-ff-ff-ff-ff static

11.0.0.5 00-0c-29-6a-07-e6 dynamic

224.0.0.22 01-00-5e-00-00-16 static

224.0.0.252 01-00-5e-00-00-fc static

 

 

Repeat these steps PC-C.

 

What virtual MAC address is being used by PC-C?

 

_______________________________________________________________________________________

 

clients.

 

R1>sh glbp brief

Interface Grp Fwd Pri State Address Active router Standby router

Gi0/1.10 10 — 150 Active 10.1.10.254 local 10.1.10.2

Gi0/1.10 10 2 — Listen 0007.b400.0a02 10.1.10.2 —

Gi0/1.20 20 — 150 Active 10.1.20.254 local 10.1.20.2

Gi0/1.20 20 1 — Active 0007.b400.1401 local —

Gi0/1.20 20 2 — Listen 0007.b400.1402 10.1.20.2 —

Gi0/1.99 99 — 150 Active 10.1.99.254 local 10.1.99.2

Gi0/1.99 99 1 — Active 0007.b400.6301 local —

Gi0/1.99 99 2 — Listen 0007.b400.6302 10.1.99.2 —

R1>

 

.

 

VLAN 10 clients.

 

 

R3>show glbp brief

Interface Grp Fwd Pri State Address Active router Standby router

Gi0/1.10 10 — 100 Standby 10.1.10.254 10.1.10.1 local

Gi0/1.10 10 1 — Listen 0007.b400.0a01 10.1.10.1 —

Gi0/1.10 10 2 — Active 0007.b400.0a02 local —

Gi0/1.20 20 — 100 Standby 10.1.20.254 10.1.20.1 local

Gi0/1.20 20 1 — Listen 0007.b400.1401 10.1.20.1 —

Gi0/1.20 20 2 — Active 0007.b400.1402 local —

Gi0/1.99 99 — 100 Standby 10.1.99.254 10.1.99.1 local

Gi0/1.99 99 1 — Listen 0007.b400.6301 10.1.99.1 —

Gi0/1.99 99 2 — Active 0007.b400.6302 local —

R3>

 

routing devices participating in GLBP.

 

reply to each client contain the MAC address of the next possible router in a round-robin fashion.

 

]

Step 13: GLBP interface tracking.

 

 

threshold, the router regains its active state.

 

s0/0/1 interface affect GLBP forwarding operations, we will need to configure tracking on these interfaces. Tracking with GLBP uses objects. The first step is to track the line protocol status of R1’s serial interface s0/0/0. On R1, issue the following command:

   

track 15 interface s0/0/0 line-protocol

 

the track object number 15.

 

Consider the example configuration below.

 

 

threshold of 105.

 

 

interface gi0/1.10

glbp 10 weighting 110 lower 85 upper 105

decrement 30

 

 

ping to the destination address 10.1.202.1. This will be useful to demonstrate the automatic failover of one AVF to the other when the tracked object decrements the GLBP weight.

 

uses R1 as its default gateway.

 

SRV1

 

ping 10.1.202.1 -t

 

down the interface s0/0/0.

   

int s0/0/0

down

 

Notice the console messages listed below.

 

*Jul 29 12:53:45.263: %TRACK-6-STATE: 15 interface Se0/0/0 line-protocol Up -> Down

*Jul 29 12:53:45.263: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 10.1.1.2 (Serial0/0/0) is down: interface down

*Jul 29 12:53:47.263: %LINK-5-CHANGED: Interface Serial0/0/0, changed state to administratively down

*Jul 29 12:53:48.263: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down

*Jul 29 12:54:19.835: %GLBP-6-FWDSTATECHANGE: GigabitEthernet0/1.10 Grp 10 Fwd 1 state Active -> Listen

 

from an active state to listen.

 

without fail. GLBP failed over automatically to the R3 device and the client experienced no disruption in service.

 

.

 

glbp

GigabitEthernet0/1.10 — Group 10

State is Active

1 state change, last state change 18:04:27

Virtual IP address is 10.1.10.254

Hello time 3 sec, hold time 10 sec

Next hello sent in 0.288 secs

Redirect time 600 sec, forwarder timeout 14400 sec

Preemption enabled, min delay 0 sec

Active is local

Standby is 10.1.10.2, priority 100 (expires in 9.376 sec)

Priority 150 (configured)

Weighting 80, low (configured 110), thresholds: lower 85, upper 105

Track object 15 state Down decrement 30

Load balancing: round-robin

Group members:

acf2.c518.0651 (10.1.10.2)

acf2.c523.7a09 (10.1.10.1) local

There are 2 forwarders (0 active)

Forwarder 1

State is Listen

2 state changes, last state change 00:05:52

MAC address is 0007.b400.0a01 (default)

Owner ID is acf2.c523.7a09

Redirection enabled

Preemption enabled, min delay 30 sec

Active is 10.1.10.2 (secondary), weighting 100 (expires in 10.592 sec)

Client selection count: 13

Forwarder 2

State is Listen

MAC address is 0007.b400.0a02 (learnt)

Owner ID is acf2.c518.0651

Redirection enabled, 599.392 sec remaining (maximum 600 sec)

Time to live: 14399.392 sec (maximum 14400 sec)

Preemption enabled, min delay 30 sec

Active is 10.1.10.2 (primary), weighting 100 (expires in 10.368 sec)

Client selection count: 13

<output omitted>

 

isten state.

 

lab, these steps have been omitted.

 

command.

 

On R1, shutdown the interface s0/0/0.

   

int s0/0/0

no shut

 

command to ensure R1 resumed its AVF role.

Step 14: Configure GLBP authentication.

 

within the incoming packet does not match the generated hash the packet is ignored.

 

 

interface GigabitEthernet0/1.10

glbp 10 authentication md5 key-string cisco123

   

0

0 authentication md5 key-string cisco123

 

interface GigabitEthernet0/1.99

authentication md5 key-string cisco123

 

NOTE: The cisco123 is used as the shared key password in this lab scenario.

 

key-string shown above.

 

Verify the GLBP operation. Ensure that the R1 is still the AVG and both routers are participating as AVFs for each configured GLBP group. If there is a problem, check the GLBP authentication configuration for errors.

 

Step 13: End of Lab

Do not save your configurations. The equipment will be reset for the next lab.

 

 

 

 

 

 

 

Device Configurations:

Below are the final configurations for each switch.

 

R1:

R1# show run brief | exclude !

Building configuration…

 

 

Current configuration : 2573 bytes

version 15.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname R1

boot-start-marker

boot-end-marker

enable secret 5 $1$8IBV$cpN/Zkg6UKXryw2kX6djn/

no aaa new-model

ip cef

no ipv6 cef

redundancy

track 15 interface Serial0/0/0 line-protocol

interface Embedded-Service-Engine0/0

no ip address

shutdown

interface GigabitEthernet0/0

no ip address

shutdown

duplex auto

speed auto

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

interface GigabitEthernet0/1.10

description Office VLAN 10

encapsulation dot1Q 10

ip address 10.1.10.1 255.255.255.0

glbp 10 ip 10.1.10.254

glbp 10 priority 150

glbp 10 preempt

glbp 10 weighting 110 lower 85 upper 105

glbp 10 authentication md5 key-string cisco123

glbp 10 weighting track 15 decrement 30

interface GigabitEthernet0/1.20

description Server VLAN 20

encapsulation dot1Q 20

ip address 10.1.20.1 255.255.255.0

glbp 20 ip 10.1.20.254

glbp 20 priority 150

glbp 20 preempt

glbp 20 authentication md5 key-string cisco123

interface GigabitEthernet0/1.99

description Management VLAN 99

encapsulation dot1Q 99

ip address 10.1.99.1 255.255.255.0

glbp 99 ip 10.1.99.254

glbp 99 priority 150

glbp 99 preempt

glbp 99 authentication md5 key-string cisco123

interface Serial0/0/0

ip address 10.1.1.1 255.255.255.252

clock rate 2000000

interface Serial0/0/1

no ip address

shutdown

interface Serial0/1/0

no ip address

shutdown

interface Serial0/1/1

no ip address

shutdown

clock rate 125000

router eigrp 1

network 10.0.0.0

ip forward-protocol nd

no ip http server

no ip http secure-server

control-plane

line con 0

logging synchronous

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

password cisco

login

transport input all

scheduler allocate 20000 1000

end

 

R2:

 

R1# show run brief | exclude !

Building configuration…

 

 

Current configuration : 2573 bytes

version 15.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname R1

boot-start-marker

boot-end-marker

enable secret 5 $1$8IBV$cpN/Zkg6UKXryw2kX6djn/

no aaa new-model

ip cef

no ipv6 cef

redundancy

track 15 interface Serial0/0/0 line-protocol

interface Embedded-Service-Engine0/0

no ip address

shutdown

interface GigabitEthernet0/0

no ip address

shutdown

duplex auto

speed auto

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

interface GigabitEthernet0/1.10

description Office VLAN 10

encapsulation dot1Q 10

ip address 10.1.10.1 255.255.255.0

glbp 10 ip 10.1.10.254

glbp 10 priority 150

glbp 10 preempt

glbp 10 weighting 110 lower 85 upper 105

glbp 10 authentication md5 key-string cisco123

glbp 10 weighting track 15 decrement 30

interface GigabitEthernet0/1.20

description Server VLAN 20

encapsulation dot1Q 20

ip address 10.1.20.1 255.255.255.0

glbp 20 ip 10.1.20.254

glbp 20 priority 150

glbp 20 preempt

glbp 20 authentication md5 key-string cisco123

interface GigabitEthernet0/1.99

description Management VLAN 99

encapsulation dot1Q 99

ip address 10.1.99.1 255.255.255.0

glbp 99 ip 10.1.99.254

glbp 99 priority 150

glbp 99 preempt

glbp 99 authentication md5 key-string cisco123

interface Serial0/0/0

ip address 10.1.1.1 255.255.255.252

clock rate 2000000

interface Serial0/0/1

no ip address

shutdown

interface Serial0/1/0

no ip address

shutdown

interface Serial0/1/1

no ip address

shutdown

clock rate 125000

router eigrp 1

network 10.0.0.0

ip forward-protocol nd

no ip http server

no ip http secure-server

control-plane

line con 0

logging synchronous

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

password cisco

login

transport input all

scheduler allocate 20000 1000

end

R3:

 

R3# show run brief | exclude !

Building configuration…

 

 

Current configuration : 2398 bytes

version 15.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname R3

boot-start-marker

boot-end-marker

enable secret 5 $1$K2en$bbda0.oigRThi/mmgC7go1

no aaa new-model

ip cef

no ipv6 cef

redundancy

interface Embedded-Service-Engine0/0

no ip address

shutdown

interface GigabitEthernet0/0

no ip address

shutdown

duplex auto

speed auto

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

interface GigabitEthernet0/1.10

description Office VLAN 10

encapsulation dot1Q 10

ip address 10.1.10.2 255.255.255.0

glbp 10 ip 10.1.10.254

glbp 10 preempt

glbp 10 authentication md5 key-string cisco123

interface GigabitEthernet0/1.20

description Server VLAN 20

encapsulation dot1Q 20

ip address 10.1.20.2 255.255.255.0

glbp 20 ip 10.1.20.254

glbp 20 preempt

glbp 20 authentication md5 key-string cisco123

interface GigabitEthernet0/1.99

description Management VLAN 99

encapsulation dot1Q 99

ip address 10.1.99.2 255.255.255.0

glbp 99 ip 10.1.99.254

glbp 99 preempt

glbp 99 authentication md5 key-string cisco123

interface Serial0/0/0

no ip address

shutdown

clock rate 2000000

interface Serial0/0/1

ip address 10.1.1.6 255.255.255.252

interface Serial0/1/0

no ip address

shutdown

clock rate 2000000

interface Serial0/1/1

no ip address

shutdown

clock rate 2000000

router eigrp 1

network 10.0.0.0

ip forward-protocol nd

no ip http server

no ip http secure-server

control-plane

line con 0

logging synchronous

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

password cisco

login

transport input all

scheduler allocate 20000 1000

end

 

DLS1:

DLS1# show run | exclude !

Building configuration…

 

Current configuration : 2432 bytes

version 15.0

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname DLS1

boot-start-marker

boot-end-marker

enable secret 5 $1$WUB8$FEnk/sOccbWN/mB.QBZ.m1

no aaa new-model

system mtu routing 1500

no ip domain-lookup

ip domain-name CCNP.NET

spanning-tree mode pvst

spanning-tree extend system-id

vlan internal allocation policy ascending

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

interface Port-channel10

switchport trunk encapsulation dot1q

switchport mode trunk

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode active

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode active

interface FastEthernet0/3

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 10 mode active

interface FastEthernet0/4

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 10 mode active

interface FastEthernet0/5

switchport trunk encapsulation dot1q

switchport mode trunk

interface FastEthernet0/6

switchport access vlan 10

switchport mode access

spanning-tree portfast

interface FastEthernet0/7

shutdown

interface FastEthernet0/8

shutdown

interface FastEthernet0/9

shutdown

interface FastEthernet0/10

shutdown

interface FastEthernet0/11

shutdown

interface FastEthernet0/12

shutdown

interface FastEthernet0/13

shutdown

interface FastEthernet0/14

shutdown

interface FastEthernet0/15

shutdown

interface FastEthernet0/16

shutdown

interface FastEthernet0/17

shutdown

interface FastEthernet0/18

shutdown

interface FastEthernet0/19

shutdown

interface FastEthernet0/20

shutdown

interface FastEthernet0/21

shutdown

interface FastEthernet0/22

shutdown

interface FastEthernet0/23

shutdown

interface FastEthernet0/24

shutdown

interface GigabitEthernet0/1

shutdown

interface GigabitEthernet0/2

shutdown

interface Vlan1

no ip address

interface Vlan99

ip address 10.1.99.3 255.255.255.0

ip http server

ip http secure-server

line con 0

exec-timeout 0 0

logging synchronous

line vty 0 4

password cisco

login

line vty 5 15

password cisco

login

end

 

DLS2:

 

DLS2# show run | exclude !

Building configuration…

 

Current configuration : 2442 bytes

version 15.0

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname DLS2

boot-start-marker

boot-end-marker

enable secret 5 $1$o4vW$5HBXnwUB08E9pBvI0yHI2.

no aaa new-model

system mtu routing 1500

no ip domain-lookup

ip domain-name CCNP.NET

spanning-tree mode pvst

spanning-tree extend system-id

vlan internal allocation policy ascending

interface Port-channel2

switchport trunk encapsulation dot1q

switchport mode trunk

interface Port-channel10

switchport trunk encapsulation dot1q

switchport mode trunk

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode active

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode active

interface FastEthernet0/3

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 10 mode active

interface FastEthernet0/4

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 10 mode active

interface FastEthernet0/5

switchport trunk encapsulation dot1q

switchport mode trunk

interface FastEthernet0/6

shutdown

interface FastEthernet0/7

shutdown

interface FastEthernet0/8

shutdown

interface FastEthernet0/9

shutdown

interface FastEthernet0/10

shutdown

interface FastEthernet0/11

shutdown

interface FastEthernet0/12

shutdown

interface FastEthernet0/13

shutdown

interface FastEthernet0/14

shutdown

interface FastEthernet0/15

shutdown

interface FastEthernet0/16

shutdown

interface FastEthernet0/17

shutdown

interface FastEthernet0/18

switchport access vlan 10

switchport mode access

spanning-tree portfast

interface FastEthernet0/19

shutdown

interface FastEthernet0/20

shutdown

interface FastEthernet0/21

shutdown

interface FastEthernet0/22

shutdown

interface FastEthernet0/23

shutdown

interface FastEthernet0/24

shutdown

interface GigabitEthernet0/1

shutdown

interface GigabitEthernet0/2

shutdown

interface Vlan1

no ip address

shutdown

interface Vlan99

ip address 10.1.99.3 255.255.255.0

ip http server

ip http secure-server

line con 0

exec-timeout 0 0

logging synchronous

line vty 0 4

password cisco

login

line vty 5 15

password cisco

login

end

 

ALS1:

 

ALS1# show run | exclude !

Building configuration…

 

Current configuration : 2119 bytes

version 15.0

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname ALS1

boot-start-marker

boot-end-marker

enable secret 5 $1$tKFf$wHvcVUvN6dKrJumt.Qy3a.

no aaa new-model

system mtu routing 1500

no ip domain-lookup

ip domain-name CCNP.NET

spanning-tree mode pvst

spanning-tree extend system-id

vlan internal allocation policy ascending

interface Port-channel1

switchport mode trunk

interface Port-channel2

switchport mode trunk

interface FastEthernet0/1

switchport mode trunk

channel-group 1 mode active

interface FastEthernet0/2

switchport mode trunk

channel-group 1 mode active

interface FastEthernet0/3

switchport mode trunk

channel-group 2 mode active

interface FastEthernet0/4

switchport mode trunk

channel-group 2 mode active

interface FastEthernet0/5

shutdown

interface FastEthernet0/6

shutdown

interface FastEthernet0/7

shutdown

interface FastEthernet0/8

shutdown

interface FastEthernet0/9

shutdown

interface FastEthernet0/10

shutdown

interface FastEthernet0/11

shutdown

interface FastEthernet0/12

shutdown

interface FastEthernet0/13

shutdown

interface FastEthernet0/14

shutdown

interface FastEthernet0/15

shutdown

interface FastEthernet0/16

shutdown

interface FastEthernet0/17

shutdown

interface FastEthernet0/18

switchport access vlan 10

switchport mode access

spanning-tree portfast

interface FastEthernet0/19

shutdown

interface FastEthernet0/20

shutdown

interface FastEthernet0/21

shutdown

interface FastEthernet0/22

shutdown

interface FastEthernet0/23

shutdown

interface FastEthernet0/24

shutdown

interface GigabitEthernet0/1

shutdown

interface GigabitEthernet0/2

shutdown

interface Vlan1

no ip address

interface Vlan99

ip address 10.1.99.5 255.255.255.0

ip http server

ip http secure-server

line con 0

exec-timeout 0 0

logging synchronous

line vty 0 4

password cisco

login

line vty 5 15

password cisco

login

end

 

 

 

 

 

 

29


Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *